liblzma: General-purpose data compression software

Description

This packages represents liblzma, a part of XZ Utils, the free general-purpose data compression software with a high compression ratio.

License

Some parts public domain, other parts GNU LGPLv2.1, GNU GPLv2, or GNU GPLv3.

Upstream Contact

http://tukaani.org/xz/

Dependencies

Type

standard

Version Information

package-version.txt:

5.2.5

Equivalent System Packages

conda:

$ conda install xz

cygwin:

$ apt-cyg install xz liblzma-devel

Debian/Ubuntu:

$ sudo apt-get install  xz-utils liblzma-dev

Fedora/Redhat/CentOS:

$ sudo yum install  xz xz-devel

homebrew:

$ brew install xz

macports: install the following packages: xz

opensuse:

$ sudo zypper install xz "pkgconfig(liblzma)"

slackware:

$ sudo slackpkg install xz

void:

$ sudo xbps-install  xz liblzma-devel

See https://repology.org/project/xz/versions

If the system package is installed, ./configure will check whether it can be used.